Home > OSPF EIGRP Redistribute Lab

OSPF EIGRP Redistribute Lab

In this GNS3 lab we will learn how to redistribute from EIGRP into OSPF and vice versa. Below is the topology used in this lab:

OSPF_EIGRP_Redistribute_topology.jpg

The purposes of this sim are:
+ Redistribute from EIGRP to OSPF and vice versa.
+ Traffic from R1 to R4 must go through the best path (after redistribution, traffic from R1 will go R1 -> R2 -> R4; this is not the most optimal path as it must go through 2 serial links. The best path is R1 -> R2 -> R3 -> R4 and we have to configure the routers to complete this task.)

You can download the initial configuration of this lab here: http://www.digitaltut.com/download/EIGRP_OSPF_Redistribute_initial_configs.zip.

Initial Configurations (which have not had the redistribute command yet):

R1(config)#interface s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.1.0
R2(config)#interface s0/1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#interface f1/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#interface s0/0
R2(config-if)#ip address 192.168.3.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
R2(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#network 192.168.3.0 0.0.0.255 area 24
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.2.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#interface f1/0
R3(config-if)#ip address 192.168.4.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.2.0
R3(config-router)#exit
R3(config)#router ospf 1
R3(config-router)#network 192.168.4.0 0.0.0.255 area 34

R4(config)#interface s0/0
R4(config-if)#ip address 192.168.3.4 255.255.255.0
R3(config-if)#interface f1/0
R3(config-if)#ip address 192.168.4.4 255.255.255.0
R4(config-if)#no shut
R3(config-if)#interface loopback0
R3(config-if)#ip address 172.16.100.1 255.255.255.0
R4(config-if)#exit
R4(config)#router ospf 1
R4(config-router)#network 192.168.3.0 0.0.0.255 area 24
R4(config-router)#network 192.168.4.0 0.0.0.255 area 34
R4(config-router)#network 172.16.100.0 0.0.0.255 area 0

After finishing the initial commands above, the routing tables of each router are shown below:

R1:
OSPF_EIGRP_Redistribute_init_R1_show_ip_route.jpg

R2:
OSPF_EIGRP_Redistribute_init_R2_show_ip_route.jpg

R3:
OSPF_EIGRP_Redistribute_init_R3_show_ip_route.jpg

R4:
OSPF_EIGRP_Redistribute_init_R4_show_ip_route.jpg

First on R2 we will redistribute routes from EIGRP to OSPF:

R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 100 metric-type 1 subnets

OSPF_EIGRP_Redistribute_EIGRP_to_OSPF_R4_show_ip_route.jpg

We can see two “O E1” routes that are being redistributed into OSPF. Now we will redistribute OSPF to EIGRP on R2:

R2(config)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500

The routing table of R1 is now learned routes to networks 172.16.100.0/24, 192.168.4.0/24 & 192.168.3.0/24 which are advertised by OSPF:

OSPF_EIGRP_Redistribute_OSPF_to_EIGRP_R1_show_ip_route.jpg

Note: The routing table of R3 is still the same because R3 had all routes advertised by OSPF. Also, R1 can now ping 172.16.100.1 successfully.

Let’s do redistribution on R3:

Redistribute EIGRP to OSPF on R3:

R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets

Now the routing table of R4 changes a bit:

OSPF_EIGRP_Redistribute_EIGRP_to_OSPF_on_R3_R4_show_ip_route.jpg

As you can see, now the external routes 192.168.1.0 & 192.168.2.0 are learned via 192.168.4.3, not 192.168.3.2.

The last thing we do is to redistribute OSPF to EIGRP on R3:

R3(config)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500

Now R2 (and R1) will use which route to go to 172.16.100.1? Let’s check the routing table of R2:

OSPF_EIGRP_Redistribute_OSPF_to_EIGRP_R2_show_ip_route.jpg

So R2 still sends traffic to 172.16.100.1 via the serial link between R4 & R2. This link is less optimal than the Ethernet link between R2 and R3. If we wish R2 to send traffic via the Ethernet link between R2 and R3, use this command:

R2(config-router)#distance eigrp 90 105

This command sets the Administrative Distance of EIGRP external route to 105, which is smaller than an OSPF route (110) so the Ethernet link between R2 and R3 will be preferred to the link between R2 & R4.

After that, the route to 172.16.100.1 is re-learned via 192.168.2.3 as an EIGRP external route.

OSPF_EIGRP_Redistribute_R2_distance_eigrp_show_ip_route.jpg

A traceroute command on R1 also confirms this:

OSPF_EIGRP_Redistribute_R1_traceroute.jpg

You can download the final configuration of this lab here: http://www.digitaltut.com/download/EIGRP_OSPF_Redistribute_final_configs.zip.

Comments
  1. Susan
    January 17th, 2017

    Hi guys, I don’t see console pup up after clicking on any routers. Can’t Start any routers in the topology. Please help. Thanks

  2. bombermag
    February 19th, 2017

    did you press play? in GNS3?

  3. Gileno
    April 21st, 2017

    Great lab thanks !!!

  4. K
    July 3rd, 2017
  5. Flaw in Topology
    August 7th, 2017

    I’m tracing from R4 to R1’s interface IP to R2…… Instead of R1 to R4’s loopback!!

    If you shut down the fast int between R3 and R2 causing the topology to reconverge from R4 thru R2… If Trace-route from R4 to R1’s interface facing R2.. It breaks. R2 seems to be unable to forward the packet to its adjacency “R1”

    However, R1 is able to ping/trace over to R4 loopback IP.

    Does anybody taken this lab this far? Any thoughts?

  6. Pk
    November 7th, 2017

    hi guys, how do we know which metric type we use when redistributing eigrp?

    Here we are redistributing as E1, why?

  7. Pk
    November 7th, 2017

    @Flaw in Topology, i just did the same, shutting the link between R3 and R2. i did a continuous ping and i dropped one packet when i shut the interface. first i did traceroute to see which pah it’s taking.

    R4#ping 192.168.1.1 repeat 100

    Type escape sequence to abort.
    Sending 100, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Success rate is 99 percent (99/100), round-trip min/avg/max = 16/68/140 ms

  8. ZSL
    February 10th, 2018

    The configuration is wrong on R3. The two F0/0 and F1/0 interfaces ip addresses are flipped. F1/0 should be the ip address 192.168.2.3 255.255.255.0, and F0/0 should be 192.168.4.3 255.255.255.0.

  9. ccnp83
    March 5th, 2018

    Hi ZSL,are you also referring to this problem i reported:

    m struggling to understand the EIGRP Redis Lab.

    Digital have presented two scenarios,one wiht serial and another with fast ether link between router 2 and router 3.

    The confusion is show command you are displaying.

    In one scenario,its the interface in the OSPF domain towards r4 from where you are gathering the BW Delay and MTU stats
    and the serial interface between r2 and r4 is also used for the BW and DElay stats.

    In contrast,another scenario when the link between the r2 and r3 is fasthethernet,you are using the show interface for the fast Ethernet link between r2 and r3 and not sticking to the original interfaces you used in the first scenario.

    How do i know why you have used two different interfaces for two different cases.

    In case 1 and case 2,both the interfaces should be the ones used in the ospf domains?

    In case 1 you are using OSPF facing interfaces for EIGRP metric where as in case 2 you are using the EIGRP facing interfaces to get the stats.please explain.

  10. CCNP wanna be
    May 24th, 2018

    In this scenario we can use metrics type E1 or E2 as the next-hop is the ASBR. The reported metrics will be exactly the same on R4 (20).

  11. EJAH!
    September 19th, 2018

    Hi!

    I followed the step by step configurations but R2 still uses O IA serial 0/0 to reach R4’s lan interface. Any feedback?

  12. 30th Nov 2018 LAB
    November 30th, 2018

    EIGRP OSPF Redistribution Sim:, EIGRP Stub Sim, EIGRP Evaluation Sim + Drag and Drop (stateless \ statefull) + a lot of questions for PPoE, SFP Alrorytm,

  13. failed-second-time
    June 8th, 2019

    I have applied this solution in Eve-Ng and worked perfect!

  14. Sepideh
    September 14th, 2019

    Hey 9tut
    Pass exam 300-101 September 11 by 790, the lab question was Redistriubute OSPF to EIGRP and route-map
    90% of question was the same
    tnx alot

  15. Net_Lover
    July 6th, 2023

    THIS LAB WAS SICK !!!

  1. No trackbacks yet.