Home > EIGRP OSPF Redistribution Sim

EIGRP OSPF Redistribution Sim

January 8th, 2015 in Lab Sim, LabSim Go to comments

Question

OSPF_EIGRP_Redistribution.jpg

Answer and Explanation:

First we need to find out 5 parameters (Bandwidth, Delay, Reliability, Load, MTU) of the s0/0/0 interface (the interface of R2 connected to R4) for redistribution :

R2#show interface s0/0/0

Write down these 5 parameters, notice that we have to divide the Delay by 10 because the metric unit is in tens of microsecond. For example, we get Bandwidth=1544 Kbit, Delay=20000 us, Reliability=255, Load=1, MTU=1500 bytes then we would redistribute as follows:

R2#config terminal
R2(config)# router ospf 1
R2(config-router)#
redistribute eigrp 100 metric-type 1 subnets
R2(config-router)#exit
R2(config-router)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500

(Notice: In fact, these parameters are just used for reference and we can use other parameters with no problem. Also, a candidate said that the simulator didn’t accept the Bandwidth of 1544; in that case, we can use a lower value, like 128.

If the delay is 20000us then we need to divide it by 10, that is 20000 / 10 = 2000)

Note: “usec” here does not mean microsecond (which is 1/1000 milliseconds) but means millisecond. In short usec = msec. I don’t know why they use the word “usec” here but just think it is “msec” (According to this link: http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094cb7.shtml#eigrpmetrics: “The delay as shown in the show ip eigrp topology or show interface commands is in microseconds”)

For R3 we use the show interface fa0/0 to get 5 parameters too

R3#show interface fa0/0

For example we get Bandwidth=100000 Kbit, Delay=1000 us, Reliability=255, Load=1, MTU=1500 bytes

R3#config terminal
R3(config)#
router ospf 1
R3(config-router)#
redistribute eigrp 100 metric-type 1 subnets
R3(config)#
exit
R3(config-router)#
router eigrp 100
R3(config-router)#
redistribute ospf 1 metric 100000 100 255 1 1500

Finally you should try to “show ip route” to see the 172.16.100.1 network (the network behind R4) in the routing table of R1 and make a ping from R1 to this network.

Note: If the link between R2 and R3 is FastEthernet link, we must put the command below under EIGRP process to make traffic from R1 to go through R3 (R1 -> R2 -> R3 -> R4), which is better than R1 -> R2 -> R4.

R2(config-router)# distance eigrp 90 105

This command sets the Administrative Distance of all EIGRP internal routes to 90 and all EIGRP external routes to 105, which is smaller than the Administrative Distance of OSPF (110) -> the link between R2 & R3 will be preferred to the serial link between R2 & R4.

A reader on our site has a closer explanation for the “distance eigrp 90 105” command so we quote it here for your reference:

The “distance” refers to the administrative distance of the routes provided by a given routing process. By default, internal (which means non-redistributed) EIGRP routes are given an administrative distance of 90 while external (redistributed from another routing process) EIGRP routes are given an administrative distance of 170. The default administrative distance of OSPF is 110. The administrative distance measures the “distance from the truth” and tells the router which routes are more trustworthy. Lower administrative distance = more trustworthy. For this reason, connected routes have an administrative distance of 0. They are the MOST TRUSTWORTHY, because they are physically connected to the router. When making a decision about which route to install in the routing table, the router looks at administrative distance first. The metric (or cost) is only considered if two routes have the same administrative distance.

In this case, R2 will learn about R4’s loopback network from both R4 and R3. The route from R4 will be in OSPF (admin distance of 110) because R2 is also running OSPF while the route from R3 will be an external EIGRP route (administrative distance of 170 by default). Since the OSPF route has a lower administrative distance, it will get placed in R2’s routing table and the R3-provided route will be ignored. This is not optimal, since the path through R3 is a faster, more reliable path. To fix this, we change the administrative distance of external EIGRP routes at R2 by using the “distance eigrp 90 105” command. This sets the administrative distance of internal EIGRP routes to the default of 90 and changes the administrative distance of external EIGRP routes to 105 (less than that of OSPF routes). Now, when R2 learns of the loopback network from R4 and R3, it will install the now lower administrative distance external EIGRP route from R3 and our traffic from R1 will take the faster path.

Note: Please check the OSPF process numbers first before typing these commands.

If you want to have a closer look at this sim and understand more about the “distance eigrp” command, please read my OSPF EIGRP Redistribute Lab in GNS3.

Other lab-sims on this site:

EIGRP Stub Sim

OSPF Sim

IPv6 OSPF Virtual Link Sim

EIGRP Simlet

Policy Based Routing Sim

Comments
Comment pages
1 2 3 5 26
  1. CoolGuy
    January 9th, 2017

    Hi NK2

    Congratss for your cisco route exam.

    I am taking the exam on 11th Jan..

    If I could get the stuff on ictpro08 at hotmail dot com that would be much appreciated…

    Thanks in advance.

  2. Drago
    January 9th, 2017

    i downloaded the lab from tut and ran in my gns3. It looks like the answer does not correspond to the lab because IEGRP is already redistributed into OSPF. We need to do redistribution the other way. From OSPF into EIGRP. Anyone noticed that the answer is wrong ?
    I might miss the explanation in the thread but really don’t want to read 30 pages of posts.

    Can you guys check the lab?

  3. AFI
    January 9th, 2017

    @ ADMIN – whoever that is.
    I dont think OSPF EIGRP redistribution lab is complete. i think there needs to be a default route in R1 for it to ping R4 loopback address.

    @drango,
    i just ran files, i had to redistribute in R2 & R3. only issue I found is mentioned above.

  4. malik
    January 10th, 2017

    In this Redistribution lab, There is no need to use match and set tag values for redistribution EIGRP to OSPF and OSPF to EIGRP?

  5. Konan
    January 10th, 2017

    Again question,what is the purpose setting metric type to 1?

  6. mirzo94
    January 11th, 2017

    Hi dear @NK2, please can you also send to me, ahilles05.94 at gmail dot com. Thank you before hand

  7. CoolGuy
    January 11th, 2017

    Cleared Exam Today … !!!!
    149Q +Tagwa 41 Qs are still valid.
    Got the followng Labs+Sim in exam
    OSPF Evaluation
    EIGRP OSPF Redistribution
    Policy Based Routing
    OSPFv3 Virtual Link
    Thanks DigitalTut and all those who shares their knowledge and useful stuff.
    — Best Of Luck —

  8. Coolguy
    January 11th, 2017

    hi NK2
    I have schedule my exam on 20th of january

    please send me engsk27atgmail.com

  9. Anonymous
    January 11th, 2017

    hi, nk2 kindly send me the dumps
    {email not allowed}

  10. prisca
    January 11th, 2017

    hi, nk2 kindly send me the dumps
    priscakashatgmail.com

  11. ahemd erlrofaie
    January 13th, 2017

    can any one send me 149+41 and 183 dumps
    i will be so grateful my email address is
    ahmedrofai at gmail dot com

  12. ahemd erlrofaie
    January 13th, 2017

    is pass4sure 150 dump is valid

  13. Thankfulguy
    January 15th, 2017

    149Q +Tagwa 41 Qs PLEASE HELP taking the exam on the 21st THANK YOU southern.kick16 @ gmail.com

  14. NK2
    January 16th, 2017

    I have sent the dumps to most of the people and i advise you to help each other. If some one is missing, they can send me a request on naveedkhalid25 at gmail dot com.

  15. ahemd erlrofaie
    January 17th, 2017

    Refer to the following configuration command.
    router(config)# ip nat inside source static tcp 172.16.10.8 8080 172.16.10.8 80
    Which statement about the command is true?

    A. Any packet that is received in the inside interface with a source IP port address of
    172.16.10.8:80 is translated to 172.16.10.8:8080.
    B. Any packet that is received in the inside interface with a source IP port address of
    172.16.10.8:8080 is translated to 172.16.10.8:80.
    C. The router accepts only a TCP connection from port 8080 and port 80 on IP address
    172.16.10.8.
    D. Any packet that is received in the inside interface with a source IP address of 172.16.10.8
    is redirected to port 8080 or port 80.

    here in tagwa dump it say the correct answer is a but i think it b , can any one advice

  16. Malak
    January 17th, 2017

    I think this command parameters is not correct:
    R3(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500

    because fast ethernet BW is 100,000 and its bandwidth is 100 witch become 10 after divided it by 10
    on other-hand I don’t think its right to change AD of EIGRP where this case a loop issue
    the rule is to make sure that AD of internal Routing AD of external EIGRP (105)

  17. Malak
    January 17th, 2017

    the rule is to make sure that AD of internal Routing less than external Routing…
    AD of internal OSPF (110) bigger than AD of external EIGRP (105), this may cause a loop

  18. malik
    January 17th, 2017

    I pass my exam today with 947 marks. 149 + 41 are 100% valid. All questions from these two dumps nothing else.
    OSPF V3
    OSPF Evaluation
    Redistribution
    PBR
    OSPF V2

    CHAP Drag and Drop

  19. freeman
    January 18th, 2017

    Can someone please send me TAGWA on dr.freeman91 at gmail . com

  20. CoolGuy
    January 20th, 2017

    Hi Guys,

    From following link CCNP Labs +149Q +Tagwa 41 Qs can be downloaded.

    Note: Remove (total 8)”$” from the link to work

    ht$$tps:$$//1drv.ms/f/$$s!Aq7EzlPsYq2YgSN-WUs6kzGVn2V9K$$

  21. CoolGuy
    January 24th, 2017

    Hi Guys,
    From following link CCNP Labs +149Q +Tagwa 41 Qs can be downloaded.
    Note: Remove (total 8)”$” from the link to work
    ht$$tps:$$//1drv.ms/f/$$s!Aq7EzlPsYq2YgSN-WUs6kzGVn2V9$$

  22. ahemd erlrofaie
    January 24th, 2017

    Hi guys, I have passed my ccnp routing exam yesterday at (23/1/2017) with score (973), actually the dumps of 149q and 41q tagwa is still valid.
    Most the question came from the 41q tagwa, so you have to study it very well,
    BUT it important to study also the dump of 183q/32q/8q because it contain a lot of questions that you will not find them in both 149q and tagwa 41q dumps, in my exam none of new questions of 183q/32q/8q came, but I recommended to studied any way
    The sim in my exam:
    -ospf eigrp redistribution
    -ospf evaluation
    -ospfv3 with virtual-link
    -ospf sim
    The drag and drop:
    -CHAP drag (in tagwa 41q)

    Important notes about the sims:
    Regarding to sims , you should be careful because you might find that there some minor changes in the sims (like ip addess, subnets , ospf process numbers , eigrp autonomous number and so on) so check with show run command if that possible, before starting the configuration to not rush to configure blindly .
    In my exam, there was some little change in ospf evaluation, I mentioning below the question with changed answer:
    The question:
    Which of the following statements is true about the serial links that terminate in R3?
    A. The R1-R3 link needs the neighbor command for the adjacency to stay up
    B. The R2-R3 link OSPF timer values are 30, 120, 120
    C. The R1-R3 link OSPF timer values should be 10,40,40
    D. R3 is responsible for flooding LSUs to all the routers on the network.
    In dumps sim you will find that the correct answer is B, but in my exam that was not true, because I found that the exam changed the link R2-R3 timers to 10,40,40 and it was point-to-point link.
    also I found The link R1-R3 timer was 30,120,120 non-broad cast link, so both of the answers A , B are wrong .
    Also D was wrong because, R3 was not the DR in all the links,
    The right answer was A, because the link R1-R3 is non-broad-cast link so neighborship should be configured manually.
    So it is important to be carful .

    Important notes about tagwa 41q dump:
    It is important to mention that in tagwa 41q dump there some questions with wrong answers, here below I mentioned the question with the wrong answers:
    Question 2
    Refer to the following configuration command.
    router(config)# ip nat inside source static tcp 172.16.10.8 8080 172.16.10.8 80
    Which statement about the command is true?
    A. Any packet that is received in the inside interface with a source IP port address of
    172.16.10.8:80 is translated to 172.16.10.8:8080.
    B. Any packet that is received in the inside interface with a source IP port address of
    172.16.10.8:8080 is translated to 172.16.10.8:80.
    C. The router accepts only a TCP connection from port 8080 and port 80 on IP address
    172.16.10.8.
    D. Any packet that is received in the inside interface with a source IP address of 172.16.10.8
    is redirected to port 8080 or port 80.
    Answer:A
    Tagawa say the right answer is A , but that wrong the right answer is B (this question came in my exam)

    Question 28
    A network engineer wants to ensure an optimal end-to-end delay bandwidth product. The delay is
    less than 64 KB. Which TCP feature ensures steady state throughput?
    A. Window scaling
    B. Network buffers
    C. Round-trip timers
    D. TCP acknowledgments
    Answer:A
    Also that wrong the right answer is B
    For the dumps, you can send me at ahmedrofaii at gmail dot com , I will be glad to send them to you freely , for routing dumps and for switching , tshoot dumps
    I wish for you good luck in your exam 

  23. ahemd erlrofaie
    January 24th, 2017

    i forget to mention that there was also in my exam
    -the policy based routing sim

  24. Hiko
    January 25th, 2017

    Thank you ahemd for sharing exam practice

  25. JIES
    January 26th, 2017

    I took the exam on January the 23rd and 149, 41 are still valid

  26. ahemd erlrofaie
    February 1st, 2017

    here i sent in link below all the dumps for the three exams
    regrading the switching exam you can depend on 191q dump
    regarding to routing exam, you will find the 149q + 41q dump , also you will find the 183q\32q\8q dump you have to study them all
    regrading to tshoot exam you will find pass4sure dump , beside the dump you have to depend on networktut site for the tshoot

    https://drive.google.com/drive/folders/0B21TuNHP-x2dc2U5MUlNOXFkd2c?usp=sharing
    ​good luck????????

  27. Shan
    February 2nd, 2017

    Hello Guys
    If any one need CCIE r/s lab version 5.0 dumb please mail me. but not free.
    nkssujith @ yahoo.com

  28. Martin
    February 5th, 2017

    ahemd erlrofaie thank you so much

  29. Anonymous
    February 8th, 2017

    Thanks for those corrections ahemd. I agree they are wrong.

  30. Digital
    February 11th, 2017

    Guys,

    Good to read from here and thanks Ahemd for those corrections – I plan to take my 300-101 next week, is 41 Tagwa dump still valid

  31. Mandark
    February 11th, 2017

    Hi All,
    Passed my ROUTE about 2 hours ago with a score of 8xx. Used only 149q and TAGWA. Simulations: eigrp/ospf redistribution,
    Ospf sim, ospf (ipv6), PBR, OSPF Evaluation. Thanks to digital tut

  32. Digital
    February 11th, 2017

    Congratulations Mandark and thanks for the updates. Still studding for mine, I am scheduled to take it next week. I need some help on the sim, I like to ask you some questions, can you reach me at {email not allowed} ??

    Thanks.

  33. Anonymous
    February 12th, 2017

    Gents,

    Regarding this 149q + 41q dump,

    somebody can give me to this 41q dump? i have only 149q

    {email not allowed}

  34. Mjereza
    February 12th, 2017

    hi guys please help with latest dumps CCNP 300-101…. email:

    j.malapane at yahoo dot com

  35. a kind
    February 12th, 2017

    Hi, I know actually there are new questions, I fail my exam because there are a lot of new question, can somebody help me with the new questions??

    thanks a lot

  36. Anonymous
    February 13th, 2017

    a kind, what sort of questions did you get? Can you recall any????

  37. a kind
    February 13th, 2017

    For example for the Ospe Evaluation the timers between R3 & R2 and R3 & R1, when you use the command for check the timers, there’s no one answer to correspond with the true timers, questions about ip sla, questions about phases of autentications, I know in some blugs I was reading that they added new questions, does some one have the new pool (New Questions) and how many new questions are?

  38. sam
    February 13th, 2017

    Please share the new questions for ccnp 300-101

  39. Nivi
    February 14th, 2017

    Guys i wrote 300-101 today and passed 816..but many questions were new..i did study 149q+41q+15q+32q+8q+182q and went, but still got around 13 new questions…please make sure u study new ones also….sorry i don’t remember the new questions, otherwise i would have posted here…

  40. quales
    February 14th, 2017

    i think cisco is running interactive tests at this point sounds like it to me with all these peeps saying we got newer questions years ago the thing wouldnt change in 3-4 years;again I think its from unskilled canidates actually making it thru an interview and cannot do the work reqiured hence getting the hiring manager in trouble now manager sees certs as an ass wipe when no tp is available. Another thing they can do is make the interview more technical mine have never been hard OSI,ports numbers? really. They should set u down in a room and give u tasks to do in gns3 that reflect what an NP should know. done u either do the task or not dont know why they dont employ this exercise it would get rid of all the real cheaters that troll this site.

  41. Borge
    February 14th, 2017

    redistribute ospf 1 metric 10000 100 255 1 1500
    question test takers has anybody had the ballz to just use:
    redistribute ospf 1 metric 1 1 1 1 1
    easier and it will work

  42. Tivo
    February 15th, 2017

    Passed today. 819. Reviewed 149q+41q. Lots of questions that weren’t in those. Perhaps there in the 183 dump. 1 new question for every 3 that I recognized. More than 10 that werent in those 2 files. Simulations same.

  43. zambia
    February 15th, 2017

    ahemd erlrofaie

    Thanks for your share…..

  44. Mpolvora
    February 19th, 2017

    good evening,

    Do I get the delivery of the 149q + 41q?

    Thanks

    {email not allowed}

  45. Mpolvora
    February 19th, 2017

    good evening,
    Do I get the delivery of the 149q + 41q?

    mpolvora at gmail dot com

    Thanks

  46. Mpolvora
    February 19th, 2017

    good evening,
    Do I get the delivery of the 149q + 41q?
    mpolvoratjp at gmail dot com
    Thanks

  47. Mohammed
    February 21st, 2017

    redistribute eigrp 100 metric-type 1 subnets
    guyz 1 silly doubt in above command metric-type 1 << is this 1 is ospf process number??

  48. Hiko
    February 22nd, 2017

    Mohammed, it defines OSPF External type. you can set 1 and 2.
    http://blog.ine.com/2011/04/04/understanding-ospf-external-route-path-selection/

  49. Anonymous
    February 23rd, 2017

    passed yesterday, got 10/12 new questions never seen in dumps (about timed access list, easy vpn, ssh block access, frame relay, ipv6); labs and simlet all from known dumps (redistribution, pbr, ospf virtual link, eigrp stub); a total of 49 items to me, most from dumps. Minimum to pass 790, scored 947.

  50. Hiko
    February 23rd, 2017

    Which dumps did you use? Please write name of dumps

Comment pages
1 2 3 5 26
  1. No trackbacks yet.