Home > Policy Based Routing Sim

Policy Based Routing Sim

February 8th, 2015 in Lab Sim, LabSim Go to comments

Question

Company TUT has two links to the Internet. The company policy requires that web traffic must be forwarded only to Frame Relay link if available and other traffic can go through any links. No static or default routing is allowed.

BGP_Policy_Based_Routing_Sim.jpg

 

Answer and Explanation:

Notice: The answer and explanation below are from PeterPan and Helper.Please say thank to them!

All the HTTP traffic from the EIGRP Network should go through Frame Relay link if available and all the other traffic should go through either link.
The only router you are able to administrate is the Border Router, from the EIGRP Network you may only send HTTP traffic. As the other people mentioned, actually it is not a BGP lab. You are not able to execute the command “router bgp 65001”

1) Access list that catches the HTTP traffic:
BorderRouter(config)#access-list 101 permit tcp any any eq www

Note that the server was not directly connected to the Border Router. There were a lot of EIGRP routes on it. In the real exam you do not know the exact IP address of the server in the EIGRP network so we have to use the source as “any” to catch all the source addresses.

2) Route map that sets the next hop address to be ISP1 and permits the rest of the traffic:
BorderRouter(config)#route-map pbr permit 10
BorderRouter(config-route-map)#match ip address 101
BorderRouter(config-route-map)#set ip next-hop 10.1.101.1
BorderRouter(config-route-map)#exit

(Update: We don’t need the last command route-map pbr permit 20 to permit other traffic according to Cisco:

“If the packets do not meet any of the defined match criteria (that is, if the packets fall off the end of a route map), then those packets are routed through the normal destination-based routing process. If it is desired not to revert to normal forwarding and to drop the packets that do not match the specified criteria, then interface Null 0 should be specified as the last interface in the list by using the set clause.”

Reference: http://www.cisco.com/en/US/products/ps6599/products_white_paper09186a00800a4409.shtml)

Note: We don’t need to use IP SLA to track the next-hop IP address as the “set ip next-hop” did this. From this link: https://www.cisco.com/c/en/us/support/docs/ip/ip-routed-protocols/47121-pbr-cmds-ce.html
“The set ip next-hop command verifies the existence of the next hop specified, and…
+ If the next hop exists in the routing table, then the command policy routes the packet to the next hop.
+ If the next hop does not exist in the routing table, the command uses the normal routing table to forward the packet.”
So if the next-hop 10.1.101.1 goes down the PBR will use normal routing table.

3) Apply the route-map on the interface to the server in the EIGRP Network:
BorderRouter(config-route-map)#exit
BorderRouter(config)#int fa0/0
BorderRouter(config-if)#ip policy route-map pbr
BorderRouter(config-if)#exit
BorderRouter(config)#exit

4) There is a “Host for Testing”, click on this host to open a box in which there is a button named “Generate HTTP traffic”. Click on this button to generate some packets for HTTP traffic. Jump back to the BorderRouter and type the command “show route-map”.

BorderRouter#show route-map

In the output you will see the line “Policy routing matches: 9 packets…”. It means that the route-map we configured is working properly.

Note: We have posted a Policy Based Routing lab on GNS3 similar to this sim with detailed explanation, you can read it here.

Other lab-sims on this site:

EIGRP Stub Sim

OSPF Sim

EIGRP OSPF Redistribution Sim

IPv6 OSPF Virtual Link Sim

EIGRP Simlet

Comments
Comment pages
  1. OR
    October 29th, 2016

    @DA I passed it 8xx!!!

  2. DA
    October 30th, 2016

    @OR…..Congrats OR

  3. DR.IP
    November 1st, 2016

    Dear friends,

    Do you have any information regarding ccnp-routing dump?????

  4. Jane
    November 4th, 2016

    Please Please Please, could somebody email me the latest dumps pdf + Labs (Packet Tracer) for CCNP route exam on jane_woken52 @ yahoo.com . I will be very thankful of you guys. Pleaseeeeeee

  5. Muhammad Afzal
    November 6th, 2016

    Dear OR & DA.

    congratulation.

    Please share dumps
    M_afzal345 @ yahoo . com

  6. Routehelp
    November 6th, 2016

    I have tried PBR lab in GNS3 with echo instead of www for testing , but policy doesn’t work ( don’t match ), any suggest ?
    BorderRouter(config)#access-list 101 permit tcp any any eq echo
    BorderRouter(config)#route-map PBR permit 10
    BorderRouter(config-route-map)#match ip address 101
    BorderRouter(config-route-map)#set ip next-hop 10.1.101.1
    BorderRouter(config)#interface fastEthernet 0/0
    BorderRouter(config-if)#ip policy route-map PBR
    debug ip policy ( status rejected )
    *Mar 1 00:12:22.503: IP: s=192.168.2.254 (FastEthernet0/0), d=10.1.101.255 (Serial0/0), len 100, policy rejected — normal forwarding ted — normal forwarding
    Please help me …
    THX

  7. Anonymous
    November 8th, 2016

    passed recently, 4 labs (exepc eigrp stub), 1 simlet ospf
    Tagwas info valid, most q-s from new

  8. ledz
    November 9th, 2016

    Hey Anonymous. What materials did u refer

  9. Papa
    November 9th, 2016

    Echo doesnt come under tcp use icmp acl

  10. Learning
    November 9th, 2016

    @ Routehelp

    Isn’t the next-hop 10.1.100.2?

    What diagram are you using?

  11. ronc
    November 16th, 2016

    guys is 183q is latest dump i got it i want confirmation

  12. Muhammad Afzal
    November 20th, 2016

    Dear AKpofure,

    Please send me PDF dumps

    m_afzal345 @ yahoo . com

  13. Anonymous
    November 20th, 2016

    Hi guys:

    Can you please let me know how you generate the http traffic on the host. It is written that there is a button on the host to test but I dont see anything. Can you please let me know how should work it out or how ping should be configured to generate http traffic?

  14. Anonymous
    November 20th, 2016

    Ok you just have to telnet with the dest. IP and port 80 and then check the PBR on the Border router. :)

  15. Gerasknd
    November 23rd, 2016

    Hi,
    Just came back from the test (passed). Explanation/Answer on this page cannot be correct as part of the requirements are as follows:
    1. All other traffic may use either link
    2. No static or default routing is allowed
    Boarder Router HAS NO 0.0.0.0 route defined or learned via BGP. With configuration offered here, HTTP traffic will take frame-relay link, but all other traffic will be dropped without 0.0.0.0 route. What I have done is this:

    BorderRouter(config)#route-map pbr permit 10
    BorderRouter(config-route-map)#match ip address 101
    BorderRouter(config-route-map)#set ip next-hop 10.1.101.1

    BorderRouter(config)#route-map pbr permit 20
    BorderRouter(config-route-map)#set ip next-hop 10.1.102.1

    Not sure if it was what Cisco had expected though…

  16. Gerasknd
    November 23rd, 2016

    One more thing, none of the commands “show route-map”, “show route-map pbr”, “show route-map all”, “show access-list 101” worked on the test. Simulation just did not accept any of the commands listed so I am not sure how we are supposed to verify operation.

  17. metastabil
    November 25th, 2016

    Hi,
    this SIM is missing the IP SLA commands, because “The company policy requires that web traffic must be forwarded only to Frame Relay link if !!AVAILIBLE!! and other traffic can go through any links”

    Commands:
    ip sla monitor 1
    type echo protocol ipIcmpEcho 10.1.101.1 source-interface Serial0/0
    frequency 10
    ip sla monitor schedule 1 life forever start-time now

    route-map PBR permit 10
    match ip address WWW
    set ip next-hop verify-availability 10.1.101.1 1 track 1

  18. Quale Martins the thrids
    November 26th, 2016

    Anonymous @salman there is no need for the of ip sla because you are using pbr with the next hop so if the next hop (10.1.101.1) goes down there will be no route for that route in your routing table and will take the normal path define by the routing table.
    Here is a reference for this:
    http://www.cisco.com/c/en/us/support/docs/ip/ip-routed-protocols/47121-pbr-cmds-ce.html
    Nam September 6th, 2016

  19. ja mor
    November 28th, 2016

    i passed the exam 300-101 With Score of 934 Dump TAGWA-TAGELSIR is valid

  20. saw
    November 28th, 2016

    Hi all,
    Today i pass 300 101
    149+40 still valid. Lab Sim not change.

    Thanks to all.

  21. Muhammad Afzal
    November 30th, 2016

    Hi, All,

    Passed yesterday, 149+40 Still valid, thanks to Tagwa.

    m _ afzal345 @ yahoo.com

  22. Muhammad Afzal
    November 30th, 2016

    Hi, All,

    Passed yesterday, 149+40 Still valid, thanks to Tagwa. this lab came with changed IP address

    m _ afzal345 @ yahoo.com

  23. Jjonathan
    December 2nd, 2016

    “Generate HTTP traffic”

    How to generate http traffic on host in the lab simulation gns3?

  24. BrunoDiaz
    December 3rd, 2016

    Jjonathan
    Telnet X.X.X.X 80

  25. RectificationAgain
    December 3rd, 2016

    @Gerasknd & @Routehelp practice in GNS3

    Combining your input and question in GNS3, I have the following working. Substituting ICMP for WWW. It will not work substituting TCP ECHO for WWW.

    access-list 101 permit icmp any any echo
    !
    route-map PBR permit 10
    match ip address 101
    set ip next-hop 10.1.101.1
    !
    route-map PBR permit 20
    set ip next-hop 10.1.102.1
    !
    interface FastEthernet0/0
    ip policy route-map PBR

  26. Jia
    December 6th, 2016

    HI ,could anyone tell please where I can get TAGWA 40 questions?… thanks

  27. Muhammad Afzal
    December 6th, 2016

    send me email, i will give you 40 questions.

  28. Jia
    December 7th, 2016

    Jia_elle@hotmail dot com

    Thanks,

  29. Kubuntu
    December 7th, 2016

    ip access-list extended WWW-TRAFFIC
    permit tcp any any eq 80
    permit tcp any any eq 443
    exit

    This access-list is more suitable, because it says “web traffic”, not just HTTP traffic. TCP port 80 for HTTP and TCP port 443 for HTTPS traffic. A similar example is in the Foundation Learning Guide book.

  30. Kubuntu
    December 8th, 2016

    I stand corrected. Took the exam today. The question says “web HTTP traffic” so there is no need to capture HTTPS traffic. Passed with 9xx. Labs OSPF, Redistribution, PBR, Virtual Link. OSPF evaluation sim, timers have changed as mentioned by others. Drag and Drop was Chap 3way handshake.

  31. Garrison
    December 11th, 2016

    @metastabil
    I agree with metastabil the question clearly states a CONDITION for the PBR which requires IP SLA

  32. Anonymous
    December 13th, 2016

    Dear friends Need 40 questions routing kindly sent it on mahmoudhamid101@gmail

  33. Salman
    December 15th, 2016

    Hi all Kindly send me the latest dumps of CCNP Route i have to give paper in next week, Thanks
    email add is “salman underscore saeed 1992 at yahoo dot com”

  34. ETHIO
    December 15th, 2016

    HI ALL
    I THINK WE NEED IP LSA FOR THIS ONE

  35. ETHIO
    December 15th, 2016

    ip sla monitor 1
    type echo protocol ipIcmpEcho 10.1.101.1 source-interface Serial0/0
    ip sla monitor schedule 1 life forever start-time now
    !

    track 1 rtr 1 reachability // MAY BE its different based on your IOS version i think

    route-map rm1 permit 10
    match ip address acl1
    set ip next-hop verify-availability 10.1.101.1 1 track 1

    ip policy route-map rm1 // ON INTERFACE FA0/0

  36. Anonymous
    December 15th, 2016

    Thanks PeterPan and Helper!

  37. BrunoDiaz
    December 16th, 2016

    Passed today.
    This PBR Sim dont accept neither IP SLA or Track commands

  38. Alice
    December 16th, 2016

    Folks iğ sla not necesray in this exam
    Just needed in real life :)

  39. Hiko
    December 20th, 2016

    if possible, send me valid dumps.
    hikoheydar @ gmail.com

  40. Nancy
    December 21st, 2016

    Trying to take CCNP Routing next week, please confirm which Sim were in the exam

  41. Yamin
    December 21st, 2016

    Guys, need to verify availability for this lab with IP Sla?

  42. grappler
    December 25th, 2016

    this lab soes’t work with me even i set same config … thoughts ?

  43. Hitham
    December 25th, 2016

    Is there any change in real exam ??

  44. Anonymous
    December 27th, 2016

    Dear All,
    Dumps is changed, I exam @ 25 Dec

  45. Anonymous
    December 27th, 2016

    Dear All,
    Most of MCQs of Dumps is changed
    Labs are not change
    I exam @ 25 Dec

  46. BRE
    December 30th, 2016

    Hello everyone. Does this sim require any additional commands? Please let me know.

  47. Leo-Decap
    January 1st, 2017

    @Anonymous Are you telling Dumps with 183q is no more valid..??

  48. zee
    January 3rd, 2017

    any one can tell me about the exact number of route maps
    because in 141 dumps he made two route maps 10 and 20
    but on digital tut he made just one route map

  49. Konan
    January 5th, 2017

    I think no need for route-map 20 clause:
    because if PBR fails,router will route as normal.Or,of course,we can add route-map 20 clause just to configuration without any match/set command.
    If you do set next-hop command for other traffic ,maybe it will be mistake.Bacause it is written that other traffic can use ANY interface.

  50. Konan
    January 5th, 2017

    Not to be risky,I think we can use permit clause 20 without any set/match command.

  51. wkk
    January 8th, 2017

    please if possible, send me valid dumps.
    chothandar79 @ gmail.com

  52. CoolGuy
    January 11th, 2017

    Cleared Exam Today … !!!!
    149Q +Tagwa 41 Qs are still valid.
    Got the followng Labs+Sim in exam
    OSPF Evaluation
    EIGRP OSPF Redistribution
    Policy Based Routing
    OSPFv3 Virtual Link
    Thanks DigitalTut and all those who shares their knowledge and useful stuff.
    Others who are preparing or ready to take exam — Best Of Luck —

  53. Waleed are you serious?
    January 14th, 2017

    Lots of new question on the exam good luck to everyone. Labs are slightly different. I can’t remember what, but they were easy

  54. NetScapper
    January 14th, 2017

    Labs were almost the same as 9tut. Wording has change. PBR still the same. New questions on the exam, if you read through CCNP Cisco Press you can eliminate the answers and go with the best one.

  55. Thankfulguy
    January 15th, 2017

    149Q +Tagwa 41 Qs PLEASE HELP taking the exam on the 21th THANK YOU southern.kick16 @ gmail.com

  56. Anonymous
    January 17th, 2017

    please send dumps (149Q +Tagwa 41 Qs)

    telgin1980 -at- gmail -dot- com

  57. malik
    January 17th, 2017

    I pass my exam today with 947 marks. 149 + 41 are 100% valid. All questions from these two dumps nothing else.
    OSPF V3
    OSPF Evaluation
    Redistribution
    PBR
    OSPF V2

    CHAP Drag and Drop

  58. HK
    January 19th, 2017

    Hello everyone, I have a question that is below.

    1) have a two internet connection in one router.
    2) Router configuration for LAN, may be create two VLANs (eg:Manager and Staff). So ManagerVlan use only one internet connection and StaffVlan also use other.
    *How to configure policy-based routing.
    If u have the same design, plz send me{ heinkyaw.phk add gmail. com }
    Plz, Let me know any suggestions…

  59. Hiko
    January 19th, 2017

    Who passed exam? Please share your practice and about dumps.

  60. CoolGuy
    January 20th, 2017

    Hi Guys,

    From following link CCNP Labs +149Q +Tagwa 41 Qs can be downloaded.

    Note: Remove (total 8)”$” from the link to work

    ht$$tps:$$//1drv.ms/f/$$s!Aq7EzlPsYq2YgSN-WUs6kzGVn2V9K$$

  61. Anonymous
    January 20th, 2017

    Please share the dump {email not allowed}

  62. Anonymous
    January 20th, 2017

    ramachandra100 @ gmail.com

  63. quales
    January 22nd, 2017

    Folks iğ sla not necesray in this exam
    Just needed in real life :)
    True the next step with policy based is implementing
    set ip next-hop verify-availability 10.1.101.1 1 track 1 with the lifetime kicker
    ip sla monitor schedule 1 life forever start-time now

  64. JIES
    January 26th, 2017

    I took the exam on January the 23rd and 149, 41 are still valid

  65. Help for pbr
    February 5th, 2017

    In 149 dumps it made two route map in bpr lap 10 and 20
    but in digitaltut solution it made just one route-map 10
    please help me what should I follow and which one is valid?????????????
    I want to attempt exam after one day so plz help me about this problem

  66. Anonymous
    February 5th, 2017

    @help for pbr

    You don’t need the permit 20 entry, it is explained at the beginning of the page.

  67. Anonymous
    February 7th, 2017

    All,

    You can test this like you would in the exam if you would have dug back into this forum’s pages to find out how. However, I will help the lazy just because so no one can say I did not make it easy on them.

    DO the sim as it says on here meaning do not change www to echo. You do not need to do that to test the result in GNS3. To test, type “telnet 10.1.101.1 80”. Run the show route-map command to see the results. Done…

    Now, get on with it!

    Cheers!

  68. duka
    February 8th, 2017

    @metastabil, you are right brother. I wonder why the site owner doesn’t update the solution with the correct configs.

    IP SLA / path control via PBR if* next hop is available.

  69. Anonymous
    February 9th, 2017

    FYI: The lab SIMs I found have different IPs going to the “HTTP Traffic” cloud and “All other traffic” cloud, so don’t get confused as you go through their explanation. I was scratching my head saying “wft???”

  70. Martin
    February 10th, 2017

    Guys, do not overcomplicate things.

    We don’t need neither IP SLA nor a 2nd pbr statement. The EIGRP protocol running on the Border Router will install the EoMPLS path in the routing table, which is used as a default route towards public destinations because of the lower distance (FastEthernet Vs. Serial, FastEthernet wins). If the Serial interface fails, its route will be simply removed from the topology, that’s it. The EoMPLS route will still be the one still installed in the routing table and it will be used to route *all* traffic, HTTP included. Regardless, IP SLA is not supported by the exam simulator. The 2nd pbr statement is not needed either because route maps do NOT work like ACLs, whatever doesn’t match it’s routed through normal forwarding, it’s NOT dropped as you may think.

    You have to understand that the lab is only a tiny part of a more complex real life scenario. If you want to proper test how the whole thing works in the GNS3 lab you need another router connected to both ISP1 and ISP2. Set up a loopback on it, advertise its address, enable the http server on the router and telnet to the loopback on port 80 from the EIGRP_Network router while debug ip policy is active on the Border router. See the difference when you telnet to different ports and when you shut the Serial down on either the Border or the HTTP_Traffic router. Telnetting to ISP1 on port 80 is NOT a reliable test because those packets will be forwarded through the Serial path regardless of PBR. When you generate HTTP traffic in the exam simulator you are actually sending packets *beyond* the ISP1 router (HTTP_Traffic in GNS3), which is why you need a further router to test the lab in GNS3.

    TL;DR: the correct answer is as follows.

    Border(config)#access-list 101 permit tcp any any eq www
    Border(config)#route-map pbr permit 10
    Border(config-route-map)#match ip address 101
    Border(config-route-map)#set ip next-hop 10.1.101.1
    Border(config-route-map)#interface FastEthernet0/0
    Border(config-if)#ip policy route-map pbr

  71. TheOnlyPrincess
    February 13th, 2017

    @CoolGuy the link you posted is NOT working

  72. PeeWee
    February 15th, 2017

    I completed this lab using GNS3 and it would ping even before the configs were completed. Also noticed that the route map showed packets matching pbr 20. This could lead back to where you should not have to enter an empty route map for pbr 20.

  73. pasca
    February 16th, 2017

    @theonlyprincess its working. i have just downloaded now. remove the $$$$$$$
    Thanks @coolguy

  74. nicki
    February 23rd, 2017

    ???

  75. nicki
    February 23rd, 2017

    The company policy requires that web traffic must be forwarded only to Frame Relay link if available ===========

    if link available ? or traffic available ?

  76. nicki
    February 23rd, 2017

    Border(config)#access-list 101 permit tcp any any eq www ===== all web traffic
    Border(config)#access-list 101 permit tcp any any eq 443 ===== all web traffic
    Border(config)#route-map pbr permit 10
    Border(config-route-map)#match ip address 101
    Border(config-route-map)#set ip next-hop 10.1.101.1 ==== send to frame relay if interface is UP
    Border(config-route-map)#set ip next-hop 10.1.102.1 ====== in case failure frame relay
    Border(config-route-map)#exi
    Border(config)#route-map pbr permit 20 ==== for all other traffic
    Border(config-route-map)#set ip next-hop 10.1.102.1
    Border(config-route-map)#interface FastEthernet0/0
    Border(config-if)#ip policy route-map pbr

  77. ruben
    February 24th, 2017

    This command:
    Border(config)#route-map pbr permit 20 ==== for all other traffic
    is not necessary.

  78. mutt
    February 24th, 2017

    hi to all

    may i have 15q please

    merter.metro (at) gmail . com

  79. Avi
    March 1st, 2017

    For exams do we need to add “any any eq www” ? or something else? thanks a lot

  80. @Mike
    March 3rd, 2017

    Plz sen me a latest dumps
    michel.darcho (at) gmail . com

  81. Anonymous
    March 7th, 2017

    @avi u need to add any any eq www
    u need to give same command as given above

  82. alim2017
    March 10th, 2017

    hello guys ,can someone send me the valid dumps for 300-101
    i’m writting my exam within four days.

    tsafongromuald at gmail dot com

    regards

  83. Anonymous
    March 12th, 2017

    i need new 15 q in ccnp route in valid dump

  84. Guru-G
    March 14th, 2017

    Pass with good marks on March 2nd. Q149/Q41/Q15 still valid. Labs OSPF Eval + PBR + OSPF Virtual Link + Route Distribution + EIGRP Stub – all on exam.

  85. Samer
    March 15th, 2017

    Hello,

    CoNgRaTs to all who just passed the exam. Hope we all do great !
    Kindly email me the latest dumps?

    Email: soso – 44000 @ hotmail . com

    Thanks in advance,

  86. Zoma
    March 15th, 2017

    Can someone send me the 15q please on:
    hazem.ahmed.abuelfotoh@ g m a i l . c o m

  87. IDN
    March 16th, 2017

    Please sent Q149/Q41/Q15 still valid… ahkmad[dot]saprudin[at]gmail[dot]com

  88. DMP CISCO
    March 16th, 2017

    All I have ccnp routing 300-101 exam tomorrow, can any one please send new 15Q for me in {email not allowed}

  89. DMP CISCO
    March 16th, 2017

    Hi All I have ccnp routing 300-101 exam tomorrow, can any one please send new 15Q for me in meta4london[at][gmail][dot]com.
    Many Thanks

  90. JRouter
    March 17th, 2017

    Anyone with verifiable Dumps please email to jfuentessenior GMAIL COM……testing on March 17……..any help for the 149+15……most appreciated!!

  91. Nila
    March 18th, 2017

    Which dumps valid for 300-101?
    Please help me.

  92. jZ
    March 20th, 2017

    any updates Jrouter? did you pass the exam?

  93. san 2017
    March 23rd, 2017

    Hi Everyone,

    Please share this dumps 149q+41q+15q or any latest valid dumps if available.

    san242721 @ gmail com

  94. ishaq
    March 27th, 2017

    i had done this lab but what is the way to test the simulation that is it working properly or nottttt

  95. DAP
    March 28th, 2017

    Guys i have a question about this . Once you have configured this and you do a
    show route-map

    if its correct In the output you will see the line “Policy routing matches: 9 packets…”. It means that the route-map we configured is working properly.

    Do we then have to do anything else in this eg trace route or prove which link its going over etc ? If so what ?

  96. DAP
    March 28th, 2017

    Just to clarify on my last comment i meant in the exam ?

  97. ci
    April 5th, 2017

    Hi,

    Please, Anyone with Dumps validated please send to email {email not allowed}…… 15 New questions !!!

    Thanks

  98. mgday
    April 6th, 2017

    Hi Everyone,

    Please share this dumps 149q+41q+15q or any latest valid dumps if available.

    {email not allowed}

  99. mgday
    April 6th, 2017

    Hi Everyone,

    Please share this dumps 149q+41q+15q or any latest valid dumps if available.

    gokdin @ hotmail.com

  100. s0laris
    April 7th, 2017

    Hi everyone,
    I am sharing 252q+149q+41q+15q dump files as below. Good luck

    https://mega.nz/#F!PA0HwLLJ!6K7RQ6Lu1O2BoNx3eDg5tA

Comment pages
  1. No trackbacks yet.