Home > Auto and Manual Summary Routes to Null0 with EIGRP

Auto and Manual Summary Routes to Null0 with EIGRP

October 21st, 2012 in Basic Labs Go to comments

In this small lab we are going to see and learn about the Null0 when a summarized route is created. The topology is simple with only two routers.

Auto_Manual_Summary_Routes_Null0_topology.jpgThe purpose of this lab is to summarize all Loopback interfaces on R2 via auto and manual summarization and advertise it to R1.

In this topology R2 has three loopback interfaces. Instead of advertising all we will summarize these loopback interfaces before sending out to R1. And we will test the effect with auto summarization and manual summarization on R2.

First I listed the initial configuration on both routers, including IP address assignments and EIGRP configuration:

R1(config)#int f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.1.0

R2(config)#int f0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#int lo0
R2(config-if)#ip address 10.1.0.1 255.255.0.0
R2(config-if)#int lo1
R2(config-if)#ip address 10.2.0.1 255.255.0.0
R2(config-if)#int lo2
R2(config-if)#ip address 10.3.0.1 25.255.0.0
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 10.0.0.0
R2(config-router)#network 192.168.1.0

Auto summarization

By default, the “auto-summary” command is enabled on R2 so R2 will summarize the loopback interfaces’ networks and advertise to R1 as 10.0.0.0/8 because it goes cross a different major network 192.168.1.0/24. Therefore in the routing table of R1 we only see 1 summarized route:

Auto_Manual_Summary_Routes_Null0_init_R1_show_ip_route.jpg

Now on R2 we can see the Null0 has been created:

Auto_Manual_Summary_Routes_Null0_init_R2_show_ip_route.jpg

So, why is a route to Null0 created? Now let’s take an example to understand the importance of this route. We suppose the “10.0.0.0/8 is a summary… Null0” line does not exist in the routing table of R2 and R1 needs to send traffic to 10.4.0.1. It looks up its routing table and see that the route to 10.0.0.0/8 is advertised via Fa0/0 (from R2) so it just forwards packets to R2. Although R2 advertised a summary of 10.0.0.0/8 but it does not have a route to 10.4.0.1 and R2 will drop this packet. That’s the lucky circumstance.

Suppose R1 is the only router connecting to the Internet so maybe on R2 the administrator wants to add a default route to R1 for Internet traffic. Something like this:

R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

(or a more preferred way is to configure the “ip default-network network-connected-to-Internet” command on R1)

Now, if R2 receives traffic to 10.4.0.1 it will forward that traffic to the default network. That means the 10.4.0.1 traffic will go back to R1 and a routing loop occurs! This is the time when the “Null0” interface comes into play!

With the summarized route 10.0.0.0/8 pointed to Null0, traffic to 10.4.0.1 will not be sent back to R1, it is sent to Null0 interface instead. And packets sent to Null0 are simply dropped without creating a routing loop.

Well, you understood why the Null0 interface is created and its purpose. Now we will explore how to create the Null0 interface with a summary route.

In fact, in the above configuration you saw a summary route pointed to Null0 created with the auto-summary feature of EIGRP. To make sure that route is created via “auto-summary”, we will try turning it off.

R2(config)#router eigrp 100
R2(config-router)#no auto-summary

After the neighbor relationship of R1 & R2 is reset, the summarized route to Null0 disappears.

Auto_Manual_Summary_Routes_Null0_R2_no_auto_summary_show_ip_route.jpg

Of course, if we enable “auto-summary” and shut down all three loopback interfaces, the summarized route to Null0 will not exist in the routing table of R2 and it will not be advertised to R1 either (even we do have a “network 10.0.0.0” under EIGRP mode).

Manual summarization

First we must turn off the auto summarization with the “no auto summary” command on R2 so that it will not cause any effect on the manual summarization.

R2(config-router)#no auto-summary

Also, if you turned off loopback interfaces, make sure to turn it on again.

Next, add the manual summarization command under Fa0/0 interface of R2:

R2(config-router)#exit
R2(config)#int f0/0
R2(config-if)#ip summary-address eigrp 100 10.0.0.0 255.0.0.0

Let’s check the routing table of R2 now:

Auto_Manual_Summary_Routes_Null0_ip_summary-address_R2_show_ip_route.jpg

A summarized route is also created like in the case of Auto Summarization for preventing routing loop. R1 also receives the summarized route to 10.0.0.0/8 only.

So now if we turn off all the loopback interfaces, will the summarized route exist in the routing table of R2? The answer is no.

Auto_Manual_Summary_Routes_Null0_manual_summary_turn_off_loopbacks_R2_show_ip_route.jpg

R2 will not advertise the summarized route to R1 either so R1’s routing table does not have this route:

Auto_Manual_Summary_Routes_Null0_manual_summary_turn_off_loopbacks_R1_show_ip_route.jpg

In conclusion, a summarized route to Null0 interface is created along with the summarization of that route. If the summarizing router does not have a specific route for a subnet of that summarized route, it will send packets to Null0, sometimes called a “black hole”. This helps prevent routing loop and reduce unnecessary traffic. We can summarize a route via auto or manual summarization. Both methods require at least one related route of the summarized route to exist in the routing table before the summarized route is advertised.

Comments
  1. Mohammed
    May 4th, 2017

    Great.!! thanks :)

  2. K
    July 3rd, 2017
  3. Ambroz
    August 15th, 2017

    Very well summarized ….

  4. Jirehnetworker
    February 16th, 2018

    just like u are talking to us in the class.. thanks for much effort

  5. TUrn Around
    August 17th, 2018

    INSTATNT DOWNLOAD here

    200-125 CCNA = 486
    100-105 ICND1 = 347
    200-105 ICND2 = 268

    300-101 ROUTE = 146 SP0T0
    300-115 SWITCH = 831
    300-135 TSHOOT = 101

    400-101 WRITTEN = 248

    Copy below link:
    http://www.yumpu.com/xx/embed/view/fkSIdylaC9co2z7v

  1. No trackbacks yet.