Home > OSPF LSA Types Lab

OSPF LSA Types Lab

April 27th, 2014 in Basic Labs Go to comments

In this lab we will learn when different types of LSA will be created. The main topic of this lab is LSA Types 1, 2, 3, 4, 5, 7. If you need to review your OSPF LSA Types knowledge, we recommend you to read our OSPF LSA Types Tutorial first.

Lab topology

OSPF_LSA_Types_Topology.jpg

You can download the initial configuration file of this lab here: http://www.digitaltut.com/download/OSPF_LSA_Types_Initial.zip.

Initial Configuration

R1:
int f0/0
ip address 12.12.12.1 255.255.255.0
no shut
int f0/1
ip address 15.15.15.1 255.255.255.0
no shut
router ospf 1
router-id 1.1.1.1
net 12.12.12.0 0.0.0.255 area 0
net 15.15.15.0 0.0.0.255 area 0
R2:
int f0/0
ip address 12.12.12.2 255.255.255.0
no shut
int f0/1
ip address 23.23.23.2 255.255.255.0
no shut
int f1/0
ip address 24.24.24.2 255.255.255.0
no shut
router ospf 1
router-id 2.2.2.2
net 12.12.12.0 0.0.0.255 area 0
net 23.23.23.0 0.0.0.255 area 1
net 24.24.24.0 0.0.0.255 area 1
R3:
int f0/0
ip address 23.23.23.3 255.255.255.0
no shut
int s0/0
ip address 38.38.38.3 255.255.255.0
no shut
router ospf 1
router-id 3.3.3.3
net 23.23.23.0 0.0.0.255 area 1
router eigrp 100
net 38.38.38.0
no auto-summary
R4:
int f0/0
ip address 24.24.24.4 255.255.255.0
no shut
router ospf 1
router-id 4.4.4.4
net 24.24.24.0 0.0.0.255 area 1
R5:
int f0/0
ip address 15.15.15.5 255.255.255.0
no shut
int f0/1
ip address 56.56.56.5 255.255.255.0
no shut
int f1/0
ip address 57.57.57.5 255.255.255.0
no shut
router ospf 1
router-id 5.5.5.5
net 15.15.15.0 0.0.0.255 area 0
net 56.56.56.0 0.0.0.255 area 2
net 57.57.57.0 0.0.0.255 area 2
R6:
int f0/0
ip address 56.56.56.6 255.255.255.0
no shut
router ospf 1
router-id 6.6.6.6
net 56.56.56.0 0.0.0.255 area 2
R7:
int f0/0
ip address 57.57.57.7 255.255.255.0
no shut
router ospf 1
router-id 7.7.7.7
net 57.57.57.0 0.0.0.255 area 2
R8:
int s0/0
ip address 38.38.38.8 255.255.255.0
no shut
int lo0
ip address 8.8.8.8 255.255.255.255
router eigrp 100
network 8.0.0.0
network 38.38.38.0
no auto-summary

The initial configuration above only assigns IP addresses to interfaces and turn on OSPF on R1 to R7 and EIGRP on R8. The IP addresses of two connected interfaces are in the form of xy.xy.xy.x/24 and xy.xy.xy.y/24 where x, y are the router numbers. All the OSPF routers have router-ids in the form of x.x.x.x. Please notice that we have not redistributed EIGRP routes to OSPF domain yet.

LSA Types 1, 2 and 3

In this topology we have 3 areas 0, 1 and 2 so we can see the first three LSA types. On R7 use the “show ip ospf database” command to view the information related to OSPF database on R7:

OSPF_LSA_Types_Initial_R7_show_ip_ospf_database.jpg

The Link IDs of Type 1 LSA are the originating router IDs. LSAs Type 1 are only sent among OSPF routers in the same area so we see R5, R6 and R7 here which are in Area 2 only.

The Link IDs of Type 2 LSA are the IP interface addresses of the DRs. So here we know R5 and R7 are the DRs. If you want to verify, you can check it with the “show ip ospf neighbor” command.

OSPF_LSA_Types_Initial_R5_show_ip_ospf_neighbor.jpg

Please notice that in this case R5 is the DR for the R5-R6 segment (because we see R6 is the BDR so we can deduce R5 is the DR) and R7 is the DR for R5-R7 segment.

The Link IDs of Type 3 LSA are the destination network addresses. They give information about every segment in our network outside of its area.

“ADV router” is the router that is advertising that information.

 

OSPF_LSAs_Types_3.jpg

The OSPF database of R4 is similar to that of R7 with three LSA Types 1, 2 and 3.

OSPF_LSA_Types_Initial_R4_show_ip_ospf_database.jpg

LSA Types 4, 5

R3:

router ospf 1
redistribute eigrp 100 subnets

After redistributing from EIGRP to OSPF, LSAs Type 4 & 5 have been created and we can see them on R7:

OSPF_LSA_Types_After_Redistribute_R7_show_ip_ospf_database.jpg

The LSAs Type 4 are generated to describe the ASBR (3.3.3.3) and the ADV (Advertising) Router is R5 (5.5.5.5). R5 sends this LSA to Area 2 to inform all routers inside this area that they can reach the mentioned ASBR through it. The Link ID of LSA Type 4 is the router ID of the described ASBR. This Type of LSA is used to support LSA Type 5 when routers from other areas want to send traffic to the external routes. For example, although R7 knows the Advertising router for the network 38.38.38.0 is R3 (3.3.3.3) via Type 5 LSA but it does not know how to reach R3. It can check LSA Type 4 and see the ADV Router for R3 is R5 (5.5.5.5) so it will forward traffic to R5. Because R7 and R5 are in the same area so R7 will surely know how to reach R5 via LSA Type 1. The pictures below show how LSA Type 4 & 5 are sent out to other areas.

OSPF_LSAs_Types_4.jpg

OSPF_LSAs_Types_5.jpg

In the topology above we can see LSAs Type 4 are not sent to the routers inside the area where the ASBR belongs to. R4 only has LSA Type 5 as shown below:

OSPF_LSA_Types_After_Redistribute_R4_show_ip_ospf_database.jpg

The reason for the absence of LSA Type 4 is R4 has already known how to reach the ASBR R3 because they are in the same area. Therefore LSA Type 4 is not necessary here.

If you want to check LSA Type 5 only, use the “show ip ospf database external” command:

OSPF_LSA_Types_After_Redistribute_R4_show_ip_ospf_database_external.jpg

There is a field named “Forward Address” which is 0.0.0.0 in the output above. “0.0.0.0” here means traffic for the advertised destination should be forwarded to the advertising router (R3, 3.3.3.3, in this case).

For LSA Type 4 only, use the “show ip ospf database asbr-summary” command:

OSPF_LSA_Types_After_Redistribute_R4_show_ip_ospf_database_asbr_summary.jpg

R4 does not receive LSA Type 4 so above field is empty.

In the next part we will continue learning about LSA Type 5 and Type 7.

Comments
  1. sara-Yemen
    June 16th, 2014

    GOOOOOOOOOOOOOOOD

  2. mkhan
    June 17th, 2014

    Thanks a lot.

  3. abohany
    June 23rd, 2014

    many thanks

  4. vignesh
    June 26th, 2014

    Thank’s for your effort to sharing Knowledge

  5. Anonymous
    July 17th, 2014

    You said:
    R5 is the DR for the R5-R6 segment (because we see R6 is the BDR so we can deduce R5 is the DR) and R7 is the DR for R5-R7 segment.

    I believe that afirmation confuses.

    And my conclusion is:
    All 3 routers are in same area so there is 1DR (router 7) & 1 BDR (router 6) which has highest router IDs

  6. Ambro
    July 18th, 2014

    I also tend to agree with “Anonymous” as election process applies whether by RID or IP address.

  7. skhan
    August 3rd, 2014

    Thank you for your efforts and time you’ve put into this.

  8. Mike Honcho
    August 10th, 2014

    good stuff !! Thanks alot

  9. Ambro
    September 12th, 2014

    Very brilliant ….. thank you DTut ..

  10. Montreal
    September 23rd, 2014

    Hi Anonymous,
    There should be no confusion as there are 3 routers in area 2 but there are TWO separate networks. The DR/BDR concept goes for networks so there will be 1 DR and 1 BDR for each network segment. segment 5-7 and segment 5-6 are separate networks so they will elect DR and BDR separately.

  11. Tamarind
    November 13th, 2014

    Very clear ! Thanks!

  12. Excellent!
    January 8th, 2015

    Thank you very much!

  13. Rafael
    January 10th, 2015

    Very good this lab!

  14. Engda
    January 10th, 2015

    Thank you so much!It was extremely helpful.

  15. Ahmed magdy
    January 23rd, 2015

    Thanks for your effort,and it would more helpful if you configured area 1 as NSSA area so that we can notice type 7 LSA, but many thanks

  16. Narsimha
    March 15th, 2015

    Thaq …. where helpful for me.

  17. Eden
    April 29th, 2015

    Good Stuff. Thanks a lot.

  18. Your boss
    May 10th, 2015

    This is gold! Thank you digitut, my eternal lover.

  19. nuur
    May 14th, 2015

    i downloaded but still its not working for me who can hellp me

  20. nuur
    May 14th, 2015

    i have seen that WARNING – VM is not running, will be unresponsive
    its not working for me

  21. Mosheen
    May 19th, 2015

    what a great explanation. I never understood better before reading this.Thumbs up.

  22. Alex
    May 28th, 2015

    Great work. Thank you so much

  23. geeking
    June 6th, 2015

    hey guys what ios image are u guys using for this? I have a lot of them but which one would u recommend?

  24. Vesuvius
    June 18th, 2015

    Thank you for this! This so clear to understand!

  25. samad
    June 25th, 2015

    Thanks a lot, your explanations were really useful.

  26. psycho
    August 12th, 2015

    All Routers hung up with a loop while booting this configs with this console output:

    *** TLB (Load/Fetch) Exception ***
    PC = 0x80008000, Cause = 0x00000008, Status Reg = 0x00408103

    I´ve tested several IOS Images. The last one was “c2600-adventerprisek9-mz.124-8a.bin”.
    What´s the problem?
    Thank you

  27. Mihai C
    September 4th, 2015

    Thanks a lot. Great work.

  28. Ahmet
    September 13th, 2015

    Thanks a lot. Very professional.

  29. Harsh
    September 29th, 2015

    Thanks a lot, your explanations were really useful.

  30. uche
    October 14th, 2015

    This is a masterpiece. Thank you.

  31. zx128k
    October 31st, 2015

    @psycho It likely a hardware issue on real kit. The TLB (Load/Fetch) Exception error message is often the result of a bus error. I would guess something is not working right or setup right if you are emulating.

  32. Wally
    December 11th, 2015

    Very nice work and details.

  33. Anonymous
    February 2nd, 2016

    hey guy ,what wunderfully explanation? I have bin blind in this chapiter, but now i am so glad for good understand. Gpd bless
    bye………………………
    claude amavi

  34. Juanlus
    March 3rd, 2016

    Thanks a lot. Great summary!

  35. BigBladda
    April 16th, 2016

    Great tutorial and lab. This has confused me for so long. I love this site!

  36. The
    August 30th, 2016

    Thankyou honestly.

  37. The
    August 30th, 2016

    Thankyou honestly.

  38. kk
    September 15th, 2016

    great

  39. monte
    September 17th, 2016

    Gents, great work. One suggestion. You should add the steps to redistribute ospf 1 into eigrp 100 at Router 3 so that all the routers can trace and ping… may further enhance the exercise, did for me

  40. Anonymous
    November 11th, 2016

    Awesome tutorial, absolutely brilliant..

  1. June 18th, 2015 at 05:11 | #1