Home > OSPF Evaluation Sim

OSPF Evaluation Sim

February 9th, 2019 in Lab Sim Go to comments

You have been asked to evaluate an OSPF network and to answer questions a customer has about its operation. Note: You are not allowed to use the show running-config command.

OSPF.jpg

Although in this sim we are not allowed to use “show running-config” command but we post the configuration here so that you can understand more about the topology.

R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 192.168.13.1 255.255.255.0
ip ospf network non-broadcast
no shut
!
router ospf 1
network 192.168.13.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
R2
interface Loopback 0
ip address 2.2.2.2 255.255.255.255
!
interface S0/0
ip address 192.168.23.2 255.255.255.0
ip ospf network non-broadcast
no shut
!
router ospf 1
network 192.168.23.0 0.0.0.255 area 0
network 2.2.2.2 0.0.0.0 area 0
neighbor 192.168.23.3
R3
interface Loopback 0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
no shut
!
interface S1/0
ip address 192.168.23.3 255.255.255.0
ip ospf network non-broadcast
no shut
!
interface S1/1
ip address 192.168.13.3 255.255.255.0
ip ospf network non-broadcast
no shut
!
router ospf 1
network 192.168.13.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 1
network 3.3.3.3 0.0.0.0 area 0
area 1 virtual-link 4.4.4.4
neighbor 192.168.23.2
R4
interface Loopback 0
ip address 4.4.4.4 255.255.255.255
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
no shut
!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
no shut
!
interface Ethernet0/2
ip address 192.168.46.4 255.255.255.0
no shut
!
router ospf 1
network 192.168.34.0 0.0.0.255 area 1
network 192.168.45.0 0.0.0.255 area 2
network 192.168.46.0 0.0.0.255 area 3
network 4.4.4.4 0.0.0.0 area 1
area 1 virtual-link 3.3.3.3
area 2 nssa
area 3 stub no-summary
R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
interface Loopback1
ip address 5.5.1.1 255.255.255.255
interface Loopback2
ip address 5.5.2.1 255.255.255.255
interface Loopback3
ip address 5.5.3.1 255.255.255.255
interface Loopback4
ip address 5.5.4.1 255.255.255.255
interface Ethernet0/0
ip address 192.168.45.5 255.255.255.0
no shut
!
router ospf 1
network 192.168.45.0 0.0.0.255 area 2
network 5.5.0.0 0.0.255.255 area 2
area 2 nssa
R6
interface Ethernet0/0
ip address 192.168.46.6 255.255.255.0
no shut
interface Loopback 0
ip address 6.6.6.6 255.255.255.255
!
router ospf 1
network 192.168.46.0 0.0.0.255 area 3
network 6.6.6.6 0.0.0.0 area 3
area 3 stub

Some notices from above configuration:

+ The OSPF network type between R2 & R3 is non broadcast.
+ R3 and R4 is running virtual-link to connect Area 2 & 3 to Area 0
+ Area 2 is a NSSA area while Area 3 is a Totally Stubby area

You can download this sim to practice at http://www.digitaltut.com/download/ROUTE_OSPF.zip. Please use GNS3 with version older than v1.0 to open it (v0.8.3.1 for example). IOS used in this lab: c3640-jk9s-mz.124-16.bin

Question 1

Explanation

To check OSPF LSA we should use the “show ip ospf database” command on R5:

R5_show_ip_ospf_database.jpg

In this sim there is no LSA Type 4 because there is no ASBR so maybe this question wants to ask about LSA Type 3 (Summary Net Link States).

Note: LSA Type 4 is generated by ABR, not ASBR but without ASBR inside the network there are no LSA Type 4 generated. For more information about OSPF LSA Types please read our OSPF LSA Types Lab tutorial.

R3 advertises LSA Type 1 to R4 then R4 converts it into Type 3 and sends to R5 (because R4 is the ABR) so we see the “Link ID” 3.3.3.3 of R3 is advertising by R4 (4.4.4.4). According to the “Age” column, this LSA was advertised 1858 seconds ago.

Question 2

Explanation

Check the Serial1/0 interface of R3 which is connected to R2 with the “show ip ospf interface serial 1/0” command:

R3_show_ip_ospf_interface_serial.jpg

There are two things we should notice from the output above:
+ The “network type” connection between R2-R3 is “NON_BROADCAST” (usually we have “BROADCAST”). OSPF neighbors are discovered using multicast Hello packets. In non broadcast environment, multicast (and broadcast) messages are not allowed so OSPF neighborship cannot be formed automatically. Therefore we have to establish OSPF neighborship manually by using “neighbor ” command under OSPF process (OSPF will send unicast Hello message to this address). For example on R2 we have to use these commands:

router ospf 1
neighbor 192.168.23.3

And on R3:

router ospf 1
neighbor 192.168.23.2

+ For non broadcast environment the default Hello timer is 30 seconds; Dead timer (time to wait before declaring a neighbor dead) is 120 seconds and Wait timer (causes the interface to exit out of the wait period and select a DR on a broadcast network. This timer is always equal to the dead timer interval) is 120 seconds. In the output we also see the default timers for non broadcast network.

Question 3

Explanation

We can check the number of executed SPF algorithm via the “show ip ospf” command on R4:

R4_show_ip_ospf.jpg

In the output above we can see SPF has been executed 9 times.

Question 4

Explanation

Area 2 (of R5) is a Not-so-Stubby area (NSSA). You can check it by the “show ip ospf” command on R4 or R5 (in Area 2 section). For example, below is the output of “show ip ospf” command on R5:

R5_show_ip_ospf.jpg

In general, NSSA is same as normal area except that it can generate LSA Type 7 (redistribute from another domain) so we can see both Loopback interfaces of R5 & R6 in the routing table of R5.

R5_show_ip_route.jpg

Note: NSSA does not receive a default route by default so you will not see a default route on R5.

Area 3 (of R6) is a Totally-Stubby area so R6 only has one default route to outside world. You can check with the “show ip ospf” command on R4 and R6 (area 3 section):

R4_show_ip_ospf_area3.jpg

R6_show_ip_ospf.jpg

Notice that on R4 you will get more detail (shows “stub area, no summary LSA”) than on R6 (only shows “stub area”).

R6 is in a totally-stubby area so we will not see any R5’s Loopback interfaces in R6 routing table:

R6_show_ip_route.jpg

Note: You can see a default (summary) route to the outside (O*IA 0.0.0.0/0 …)

Comments
Comment pages
1 10 11 12 1016
  1. Anonymous
    November 30th, 2019

    Anyone have topology for EVE-NG rather then GNS3?

  2. Hollywood0728
    December 2nd, 2019

    So what commands are actually able to be ran for this sim?

  3. Anonymous
    December 13th, 2019

    Hi, I have router and switch dumps. I passed route and switch exams with those dumps which are totally valid. I need tshoot dumps. We can exchange dumps. My email: leyla.selimov93@ gmail.com

  4. Anonymous
    December 15th, 2019

    Hello,

    The Q2 Answer must be A, but I simulated the lab in gns3 and the answer B is corrected also in my lab.

  5. gui
    December 17th, 2019

    @CCNP Dumps
    recording to official Cisco documents, there is no additional configuration:
    https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6_basic/configuration/xe-3se/5700/ip6-statlss-auto-xe.html

  6. gui
    December 17th, 2019

    Which statement about stateless and stateful IPv6 auto configuration is true?
    A. Both stateless and stateful autoconfiguration require no additional setup
    B. Stateless autoconfiguration requires additional setup, whereas stateful autoconfiguration requires no additional setup
    C. Stateless autoconfiguration requires no additional setup, whereas stateful autoconfiguration requires additional setup
    D. Both stateless and stateful autoconfiguration require additional setup

  7. Switch
    December 30th, 2019

    I found my issues with the OSPF lab setup. I was going by the diagram to select my modules but the configs in the zip file are different from the diagram. The config files all use FE for the Ethernet ports whereas the diagram lists them as E0 but also the shown config has Ethernet instead of FE. Big difference when getting this setup. Some good troubleshooting as well.

  8. Ezio
    January 3rd, 2020

    Where are the questions ?

  9. Lito
    January 7th, 2020

    Any have the updated configs for GNS3 2.x?

  10. kabe
    January 8th, 2020

    @Ezio: all lab sim from page 437 of Route_Oct_2019.pdf

  11. CiscoDaddy
    January 13th, 2020

    Im needing to renew my CCNP early now, with the structural changes.

    With Cisco.Pass4sure.300-101.v2017-09-26.by.Matt.90q.vce NONVALID, does anyone have valid dump for the exam?

    Thanks in advance

  12. Switch
    January 16th, 2020

    @all who have taken exam
    On question 3 looking for the SPF number can this command be used on the exam lab? It shows the SPF number for each area quicker.
    show ip ospf statistics
    R4#show ip ospf statistics

    OSPF Router with ID (4.4.4.4) (Process ID 1)

    Area 0: SPF algorithm executed 5 times

    Area 1: SPF algorithm executed 6 times

    Area 2: SPF algorithm executed 5 times

    Area 3: SPF algorithm executed 5 times

  13. Passed CCNA exam 16th Jan 2020
    January 19th, 2020

    Hey I passed the CCNA exam on 16th January 2020 with the 9tut CCNA SIM labs. Does 9tut also have study material for CCNP Route Switch and TSHOOT topics.

  14. Abdul Qadir
    January 20th, 2020

    If we put “ip ospf ” command under interface then what type of LSA will be shown

  15. Kaiser
    January 20th, 2020

    But where are the questions?

  16. SuperConfused
    January 21st, 2020

    Is the answer for question 2 wrong? it says that the answer is B. But the explanation speaks as if the answer is A. And when I answer this question through another provider the correct answer given is A.

    Question 2

    Check the serial links connected to R3. Which statements are correct?
    A. The neighbor command must be used on R1-R3 link to keep the adjacency up****
    B. The OSPF timer values of R2-R3 link are 30, 120, 120
    C. The OSPF timer values of R1-R3 link should be 10,40,40
    D. R3 must flood LSUs to all the routers on the network.

  17. madestro
    January 23rd, 2020

    @SuperConfused

    The wording on the answer seems incorrect to me, it says the neighbor command MUST BE USED to keep the adjacency up, that’s not true. It must be used to create the adjacency but after that it should stay up provided the dead timer of 120 doesn’t expire.

    B is clearer though as it shows it right there on the output of “show ip ospf interface serial1/0”

  18. RealName
    January 24th, 2020

    @SuperConfused

    Also note that you only need need neighbor statement on the hub to bring up the neighbor relationship. it’s not needed on both routers, so it’s better to enable it on the hub router

  19. tammo
    January 28th, 2020

    hello all,
    I want web site for Microsoft Windows Server same 9tut.
    please I want your help.
    thanks

  20. OperatorGye
    February 10th, 2020

    About Q2, the right question is B. If we base on explanation, where you use “show ip ospf database” command at R5, note that LSA Type 3 (Summary Net Link State) with link id 1.1.1.1 advertised by R4 is present. If the “neighbor” statement is not present on R1-R3, then why is this entry present within LSA? … Yes, because “neighbor” statement is actually there. If there weren’t adjacency this entry would not be present. I tested it in GNS3 and is correct.

    Hope it helps…

  21. bobby charlton
    February 12th, 2020

    some have done the exam recent, it is allowed to use question mark on this sim?

  22. CCNPro
    February 16th, 2020

    @bobby charlton,

    no, it is never allowed to use “?” and I believe using “pipe |” is also tilted but this is fine to do this way.
    In realworld you can use anything but in the exam and reaching to a CCNP level may presume that you at least know by heart what are the possible commands you need. If not, there is no real need to have this certificate.

  23. eigrp
    February 18th, 2020

    @bobby churlton – yes , you can use the ‘?’

  24. Alex B
    February 28th, 2020

    Q2: The right answer is B.
    I think the answer A is not correct, because it is a P2P link and it is by nature a Broadcast. In this case it is not necessary to establish a statically neighborship. Here is a link with an explanation https://community.cisco.com/t5/routing/neighbor-command-in-router-ospf-command/td-p/1564193. (s. explanation of cadet alain.)

  25. Nexus
    May 7th, 2020
  26. jbahmedkhan@gmail.com
    December 4th, 2020

    Hello guys,
    Anyone have dumps CCNA 200 301please share with me I want to give my exam ccna
    Thank you

Comment pages
1 10 11 12 1016
  1. No trackbacks yet.